BDisk

  • Status Closed
  • Percent Complete
    100%
  • Task Type Feature Request
  • Category Documentation
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version 1.0
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: BDisk
Opened by Anonymous Submitter - 08.07.2019
Last edited by brent s. - 06.08.2019

FS#66 - I'm sorry, he's http://xhub.in.net/ Redtube Sofinnova was one of the investors in a 47.1 million S

I'm sorry, he's http://xhub.in.net/ Redtube Sofinnova was one of the investors in a 47.1 million Swiss franc ($50.6 million) fundraising by Auris Medical in April. The group plans to take another punt on a Swiss biotech company in the next month or so, Healy said.
Closed by  brent s.
06.08.2019 15:14
Reason for closing:  Not a bug

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing