BDisk

  • Status Closed
  • Percent Complete
    100%
  • Task Type Feature Request
  • Category Core
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version 1.0
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: BDisk
Opened by GI Jack: All American zero - 10.02.2018
Last edited by brent s. - 10.02.2018

FS#41 - Feature Request/Design Element: Move to profile based config

As current, bdisk is configured to expect one build configuration per system. This is terrible for both workflow and for sharing your configurations.
<p>
Suggestion is to move to an instanced profile based solution.
</p><p>
i.e.
</p><p>
move /var/lib/bdisk to /usr/share/bdisk/defaultprofile
</p><p>
move /etc/bdisk/build.ini to /usr/share/bdisk/defaultprofile
</p><p>
each profile is and instance of this template, with build.ini in the root. default libs are in the same dir as build.ini
</p><p>
This allows for many profiles, and profiles to be shared and worked on on git.
</p><p>
When bdisk becomes multi-staged. There should be an option for bdisk --init-profile [directory] which creates a new project profile at specified directory, $PWD if blank</p>

Closed by  brent s.
10.02.2018 22:09
Reason for closing:  Not a bug
Admin
brent s. commented on 10.02.2018 22:09

this is invalid. https://git.square-r00t.net/BDisk/tree/bdisk/bdisk.py#n59

 

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing